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Using the 2011 Elevation Data 
 
 
This guide provides instructions for the tasks listed below. All tasks can be carried out using the 
Christmas Island GIS or the Cocos Island GIS by altering the instructions for your required dataset. If 
you do not have the required plugins please refer to the ‘Installing Plugins in QGIS’ guide in the GIS. 
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Finding the Elevation of a Specific Location 
 

1. Begin by launching a project from the ‘View spatial data’ page.  
 

 
 

2. Pan and zoom to the area of interest. 
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3. Click on the Digital Elevation Model layer in the list on the left. Note that the layers listed will 

vary between projects although the Digital Elevation Model will always be at the end of the list. 

4. Next click the identify button  
 

 
 
 

5. Click anywhere on the map to find the elevation at that point. The elevation, in meters, will be 
shown as the ‘Band 1’ value in the Identify Results window. You can click a new location 
without having to close the ‘Identify Results’ window. 
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Viewing Elevation by Colour 
 

1. Begin by launching a project from the ‘View spatial data’ page.  
 

 
 

2. Pan and zoom to the area of interest. 
 

 
 

3. Right click the Digital Elevation Model layer from the list on the left, then click Properties. 
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4. Under the ‘Style’ tab change the ‘Color map’ property to Colormap using the dropdown list.  
 

 
 
 

5. Next click on the Colormap tab. 
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6. Click the ‘Load color map from file’ icon (in red below). A new window should pop-up.  
 

 
 

7. Within the new window navigate to one of the following folders (the first one if you are using 
the Christmas Island GIS package and the second if you are using the Cocos Islands GIS): 

 
\\CIGIS\height_data\2011_LiDAR_survey\digital_elevation_model  (Christmas Island) 
\\CocosGIS\data\height_data\digital_elevation_model\    (Cocos Islands) 
 

8. Select the DEM_colour_map.txt file and then click ‘Open’. 
 

 
 

9. Now click OK in the ‘Layer Properties’ window. 
 

10. Drag and drop the Digital Elevation Model layer to the top of the layer’s list and turn it on. It 
may take some time for the colourmap to load. Colours will now displayed based on ground 
elevation. 
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11. To change the colour scheme and/or the height at which the colours change right click the 
Digital Elevation Model layer from the list on the left, then click Properties. 

 
12. Within the Colormap tab the following can be edited: 

a. Number of colours displayed (by using the add and delete entry buttons). 
b. The value at which the colours change and the associated colour (by double-clicking 

on the colour or value).  
c. Colour interpolation. Note that ‘Linear’ interpolation will give a smoother output. 

 
13. Once you are happy with the settings, click the save button (shown in red below) and save 

your settings as a text file. This can then be loaded each time you wish to colour the layer. 
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Note: You can alter the transparency of the colourmap under the ‘Transparency’ tab in ‘Layer 
Properties’. 
  
One practical example where using a colourmap would be of use is in locating all low lying urban areas 
on Home Island and highlighting them in a specific colour, as shown in the four images below. 
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Generating Contours 
 
Contours of any interval can be generated for a specific area from the digital elevation model.  
 

1. Begin by launching a project from the ‘View spatial data’ page.  
 

 
 

2. Pan and zoom to the area of interest. 
 

 
 

3. Ensure the Digital Elevation Model 2011 is turned on and the Orthophotograph layer is turned 
off. 
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4. In the top menu bar click Raster > Extraction > Clipper. The clipper tool should appear.  If you 
do not have the Raster menu, click Plugins > Manage Plugins and turn on the GdalTools 
plugin from the list. 

 

 
 
5. The clipper tool can be used to extract a section of the digital elevation model which will be 

used as the area over which to generate contours. From the ‘Input file’ dropdown list 
(highlighted in orange below) select the DEM layer. 

 
6. Click ‘Select’ in the ‘Output file’ line (in green) and select a folder and filename for this smaller 

DEM to be saved to, ensuring the filename ends with .tif. Alternatively, you could copy and 
paste the folder address from Windows Explorer, and type in the intended filename at the end.  

 
7. Check the ‘No data value’ box (in blue). 

 
8. Drag a box on the map around the area you are interested in. This will be the area over which 

the contours will be generated.  
 

9. Now check the ‘Load into canvas when finished’ box (in red), and click OK.  
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10. Once processing is complete, click OK on the pop-up window and then click ‘Close’ in the 

clipper tool. The DEM extract should appear as a new layer in the layer list. 
 
Note: The DEM extract consists of a single grey tone. If you wish to see the height 
differentiation in colour within this part of the map then right-click on the extract layer and then 
click ‘Stretch using current extent’. Otherwise proceed to the next step. 
 

  
 

11. Turn the orthophotography layer back on in the layers list. 
12. Next click Raster > Extraction > Contour in the top menu bar. The contour tool should appear. 
 

 
 

13. From the ‘Input file’ dropdown list at the top (highlighted in orange below) select the smaller 
DEM layer that you just extracted, now a new layer.  

 
14. Click ‘Select’ in the ‘Output file’ line (in green) and select a folder and filename for the contour 

layer to be created. The contour tool will automatically put a .shp at the end of the filename.  
 

15. Select your preferred contour interval (in blue). The default setting is 10. 
 

16. Finally check the two boxes (in red) and then click OK.  
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17. Once processing is complete a confirmation window will appear. Click OK and then close the 
contour tool. 

 

 
 
18. A new contour layer should have appeared in the list of layers. You can now turn off the DEM 

layers and the new contours will display over the backdrop of the orthophoto as shown below. 
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Generating Slopes 

 
An area of a map can be selected for which to generate slopes. The initial steps are the same as the 
Generating Contours guide but will be outlined again below.  
 

1. Begin by launching a project from the ‘View spatial data’ page.  
 

 
 

1. Pan and zoom to the area of interest. 
 

 
 
 

1. Ensure the Digital Elevation Model 2011 is turned on and the Orthophotography layer is turned 
off. 
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2. In the top menu bar click Raster > Extraction > Clipper. The clipper tool should appear.  If you 
do not have the Raster menu, click Plugins > Manage Plugins and turn on the GdalTools 
plugin from the list. 

 

 
 
3. The clipper tool can be used to extract a section of the digital elevation model which will be 

used as the area over which to generate contours. From the input file dropdown list 
(highlighted in orange below) choose the DEM layer. 

 
4. Click ‘Select’ in the ‘Output file’ line (in green) and select a folder and filename for this smaller 

DEM to be saved to, ensuring the filename ends with .tif. Alternatively, you could copy and 
paste the folder address from Windows Explorer, and type in the intended filename at the end.  

 
5. Check the ‘No data value’ box (in blue). 

 
6. Drag a box on the map around the area you are interested in. This will be the area over which 

the contours will be generated.  
 

7. Now check the ‘Load into canvas when finished’ box (in red), and click OK.  
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8. Once processing is complete, click OK on the pop-up window and then click ‘Close’ in the 

clipper tool. The DEM extract should appear as a new layer in the layer list. 
 
Note: The DEM extract consists of a single grey tone. If you wish to see the height 
differentiation in colour within this part of the map then right-click on the extract layer and then 
click ‘Stretch using current extent’. Otherwise proceed to the next step. 
 

  
 

9. Turn the orthophotography layer back on in the layers list. 
 

10. The ‘Raster Terrain Analysis plugin’ is needed in order to generate slopes. In the top menu bar 
click Plugins > Manage Plugins and check that the tick box next to ‘Raster Terrain Analysis 
plugin’ is turned on. 
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11. Right-click somewhere in the upper toolbar area and then select ‘Plugins’.  
 

 
 

12. You can move the plugins toolbar around the workspace to any place that you like.  
 

 
 

13. In the plugins toolbar, click the Raster Terrain Analysis plugin icon ( ). The ‘Raster based 
terrain analysis’ window will appear. 

 
14. Leave the ‘Analysis’ setting on ‘Slope’ (below in blue), which it should be by default. 

 
15. From the ‘Input layer’ dropdown list (in orange) select the smaller DEM layer that you just 

extracted, now a new layer. 
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16. Click the ‘…’ button in the ‘Output layer’ line (in green) and select a folder and filename for the 
slope layer to be created. The plugin will automatically put a .tif at the end of the filename.  

 
17. Finally check the ‘Add result to project’ box so that the new layer will be added to the project 

once generated, and then click OK. 
 

 
 

18. Once processing is complete a new slope raster layer should appear in your layer list. The 
extract consists of a single grey tone. To view the differences in slope across the selected area 
right click on the new layer and click ‘Stretch using current extent’. 

 

 
 

Note: The terrain analysis plugin has several alternative options including aspect and ruggedness 
calculations.  
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Viewing a Ground Profile 
 

2. Begin by launching a project from the ‘View spatial data’ page.  
 

 
 

2. Pan and zoom to the area of interest. 
 

 
 

3. In the menu bar at the top Click Plugins > Manage Plugins and check that the tick box next to 
the ‘Profile’ plugin is turn on. 
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4. Select the Digital Elevation Model layer from the layer list on the left. 
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5. Click the profile icon ( ). Note: If the icon is not showing click Plugins > Analyses > 
Terrain profile. The Profile plugin is now active. 
 

 
 

6. You can now draw a line on the map by clicking once to start drawing and clicking again to 
finish drawing. This line marks out a transect of terrain which will be the basis of the profile. 
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7. After drawing the line the following window will automatically appear displaying the ground 
profile of the line. The elevation is on the y-axis. 
Note: to draw a line for a different transect you need to first close this window. 

 

 
 

5. Within your chosen transect you can zoom in to examine a specific section by drawing a box 
around it, as shown in the image below. 
Note: to zoom back to the original transect right click anywhere in the Profile window. 

 
 

As an example the following image is zoomed-in to the segment of the profile shown above by 
the blue box. 
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6. You can click the statistics tab to see the maximum and minimum heights on the line. This 
could be used to calculate drop, for instance. You can save the profile diagram to a PDF by 
clicking the ‘Save as PDF’ button at the bottom. 
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A Profile Example 
 
As an example an elevation profile will be generated for a section of the east coast of Christmas Island 
shown below in the photo by A and B.  
 

 
 
The location of the photo is shown below on the Christmas Island map. The transect goes from east to 
west. 

 
 

A 

B 
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The following chart is the profile generated for the above transect using the previous steps. Beneath it 
is the original photo for comparison. 
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Slope Layer Profiles 
 
This process can also be performed on a slope layer within the elevation project. An example where 
this would be useful is in designing a path or road where the slope cannot be above a certain degree.  
 

 
 
The following profile graph is based on a slope layer. 
 

 
 
Error Messages 
 
Note that when the profile plugin is turned on and you attempt to close QGIS you may get an error 
message similar to the one shown below. It is safe to ignore this bug and click the ‘Close’ button. 
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 Calculating Average Ground Height from a Digital Elevation Model 

The digital elevation model produced from the LiDAR data can be used to calculate volume. This guide 
shows a simple example of calculating the volume of soil required to raise an area to a certain height. 
The method can be adapted for other locations. 
 
The low lying area in the pictures below is regularly water logged and in time may extend across the 
island to the lagoon. It may be possible to raise the area to a certain height in order to stop this 
occurring. 
 

 
 

   
 

1. Start by opening any project from the View Spatial Data Page 
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2. Ensure the Digital Elevation Model layer is turned on and then in the top menu bar click Raster 
> Extraction > Clipper. If you do not have the Raster option displaying go to Plugins > Manage 
Plugins > turn on GDAL tools. 

 
3. The clipper tool can be used to extract a section of the digital elevation model on which to 

calculate volume. From the input file dropdown list (highlighted in orange below) choose the 
DEM layer 

 
4. Click ‘Select’ in the ‘Output file’ line (in green) and select a folder and filename for this smaller 

DEM to be saved to, ensuring the filename ends with .tif. Alternatively, you could copy and 
paste the folder address from Windows Explorer, and type in the intended filename at the end. 

 
5. This time make sure the ‘No data value’ box (in blue) is left unchecked as selections of No 

Data will generate problems. The ‘Load into canvas when finished’ box, however, should be 
checked (in red).  

 
6. Drag a box on the map around the area you are interested in and click OK. 

 

 
 

7. Once processing is complete, click OK on the pop-up window and then click ‘Close’ in the 
clipper tool. The new DEM extract will appear in the layer list. 
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8. Right click on the new layer in the layer list and select ‘Properties’. 
 

 
 
Click the metadata tab. The third section, called ‘Band 1’, shows the statistics for the area. 
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9. Calculate the required elevation of the area, and then subtract the mean of the area based on 
the statistics. 

 
In our example the area needs to be raised to around 2.7m (the elevation of the location water 
flows over the sand dunes). The mean elevation is 0.9m. Although by taking into account that the 
area is covered in around 20-30cm of water the mean is actually around 0.7m. 
 
Mean = 0.7 
Required = 2.7 
 
Therefore the area needs to be raised by approximately 2m.  
 
10. Measure the size of the area using the area measurement tool. 

Note: you can finish drawing the area by right clicking, instead of left clicking, the final point. 
 

 
 

11. Multiply the area by the height to be raised to get the cubic metres of sand required. 
 
2 x 40,000 = 80,000 cubic metres of sand 
 



      Using the 2011 Elevation Data 

  Page 30 of 34 

Generating Vegetation Height Statistics (ArcMap) 
 
This guide shows how to generate canopy height statistics (average, min, max, standard deviation). 
The example is a general example using all areas that have been cleared in the past on Christmas 
Island. Unlike the other guides, this guide uses ArcMap. 

 
1. Open a project in ArcMap which has the canopy height model active. 

 
2. Add a polygon to the map that defines the area you are interested in, in this case the clearing 

shapefile. If you are interested in a specific area that is not already covered by a polygon layer 
you will need to create one.  

 
3. Open the toolbox. 

 

 
 

4. In the toolbox window click Spatial Analyst Tools > Zonal > Zonal Statistics as Table. 
Note: you will require a ‘Spatial Analyst’ license to open this tool. 
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5. In the Input raster or feature zone data line select the layer than defines the areas of interest.  

 
6. In the Zone field select the attribute which is unique to each area of interest. In most cases this 

will be a unique identifier for each individual polygon. In other cases you may wish to generate 
statistics for groups of areas, for example the average height of all areas planted in a certain 
year in which case you would use the year attribute in the Zone field. 

 
7. In ‘Input value raster’ select the Canopy Height layer, then click ‘OK’. 

 

 
 

8. Once the statistics have been generated a table will display in the layers list. Right click the 
table and then click ‘Open’. 
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9. The table will give the statistics min, max, range, mean, and standard deviation for each 

polygon. 
 

 
 

10. To join this information to the original dataset right click the original dataset in the layer list, 
then click ‘Joins and Relates’, and then ‘Join…’. 

 

 
 

11. The field used as the identifier when running the Zonal Statistics should be used in the drop-
down list marked with a ‘1’ and the one marked ‘3’. 
 

12. The generated table should be used in drop-down list ‘2’. 
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13. Click OK. If the following message appears click Yes. 
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14. The Zonal Statistics table has now been joined to the original dataset. You can display the new 
data visually by right clicking on the original dataset layer in the layers list and then clicking 
‘Properties’. Select ‘Symbology’ from the tabs at the top and then ‘Quantities’ in the list on the 
left. Set the ‘Value’ dropdown list to the desired field and change any other setting to suit your 
preferences. Then click ‘OK’. 

 

 
 

 
 
 


